Account creation latency
Incident Report for Branch
Resolved
This incident has resolved
Posted Jan 21, 2025 - 12:59 CST
Identified
Branch's KYC vendor is currently having an issue with increased latency leading to higher error rates for account creation.
Posted Jan 21, 2025 - 12:06 CST
This incident affected: Core Platform Function (Onboarding).