ACH processing delay
Incident Report for Branch
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 13:06 CST
Investigating
Branch is currently investigating a delay in ACH processing with it's banking partner.
Posted Jan 16, 2025 - 12:10 CST
This incident affected: Core Platform Function (ACH).