Potential issue with disbursements

Incident Report for Branch

Resolved

For a period of time, errors were returned for disbursement requests, though they were processed correctly.
Posted Mar 04, 2026 - 18:21 CST

Investigating

Disbursements are impacted by a system issue. Branch Engineers are investigating.
Posted Mar 04, 2026 - 17:56 CST
This incident affected: Core Platform Function (Disbursements).