Wallet Creation service impact

Incident Report for Branch

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 11:08 CST

Monitoring

Wallet Creation has been stable for a few minutes. Branch is continuing to monitor the situation.
Posted Jan 15, 2026 - 10:43 CST

Investigating

Branch's KYC vendor is having a service impacting issue. As such, Wallet Creation capabilities are affected.
Posted Jan 15, 2026 - 10:27 CST
This incident affected: Core Platform Function (Onboarding).