Services unavailable

Incident Report for Branch

Resolved

Issue was related to a DNS update. It has been resolved and services restored.
Posted Jul 08, 2025 - 10:37 CDT

Update

We are continuing to investigate this issue.
Posted Jul 08, 2025 - 10:26 CDT

Investigating

A number of services are unavailable. Branch's technical teams are actively engaged in troubleshooting.
Posted Jul 08, 2025 - 10:24 CDT
This incident affected: Client Services (Pay Admin, Branch API) and Core Platform Function (Disbursements, Onboarding, Sandbox).