PayAdmin issue

Incident Report for Branch

Resolved

This incident has been resolved.
Posted May 07, 2025 - 10:16 CDT

Update

When navigating to certain parts of the app, a user may get stuck. Logging out and back in resolves the issue.
Posted May 07, 2025 - 09:31 CDT

Investigating

Branch is investigating this issue.
Posted May 07, 2025 - 09:25 CDT
This incident affected: Client Services (Pay Admin).