Potential ACH Processing Delays

Incident Report for Branch

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 14:04 CST

Investigating

Branch is actively investigating a potential service disruption impacting ACH deposits and transfers due to a processing delay the Federal Reserve is currently experiencing. We apologize for the inconvenience. Please visit https://branch.statuspage.io/ for most recent updates.
Posted Mar 03, 2026 - 09:50 CST
This incident affected: Core Platform Function (ACH).