Customers may be experiencing ACH delays.

Incident Report for Branch

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 12:56 CDT

Monitoring

The issue has been identified. Some ACH processing may still be delayed. Branch is working with it's banking partner to resolve and monitor the issue.
Posted Mar 21, 2025 - 11:34 CDT

Investigating

Branch is investigating with it's banking partner.
Posted Mar 21, 2025 - 09:38 CDT
This incident affected: Core Platform Function (ACH).