Service provider issues

Incident Report for Branch

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 15:00 CST

Monitoring

The vendor has implemented a fix and services appear to be returning to normal.
Posted Jan 22, 2026 - 13:36 CST

Update

We are continuing to work on a fix for this issue.
Posted Jan 22, 2026 - 12:58 CST

Identified

One of Branch's vendors is currently experiencing an outage. New user signups and disbursements may be affected. End users will not be able to access card controls.
Posted Jan 22, 2026 - 12:09 CST
This incident affected: Client Services (Pay Admin), Core Platform Function (Disbursements, Onboarding), and Card Network.